Vital Information on This Issue
Vulnerabilities in PHP Running Version Prior to 5.3.22 is a high risk vulnerability that is one of the most frequently found on networks around the world. This issue has been around since at least 1990 but has proven either difficult to detect, difficult to resolve or prone to being overlooked entirely.
|Vulnerability Name:||PHP Running Version Prior to 5.3.22|
|Summary:||Multiple vulnerabilities have been found in PHP: * ext/soap/soap.c in PHP before 5.3.22 and 5.4.x before 5.4.13 does not validate the relationship between the soap.wsdl_cache_dir directive and the open_basedir directive, which allows remote attackers to bypass intended access restrictions by triggering the creation of cached SOAP WSDL files in an arbitrary directory. * The SOAP parser in PHP before 5.3.22 and 5.4.x before 5.4.13 allows remote attackers to read arbitrary files via a SOAP WSDL file containing an XML external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue in the soap_xmlParseFile and soap_xmlParseMemory functions.|
|Impact:||Allows remote attackers to read arbitrary files.|
|Nist NVD (CVSS):||AV:N/AC:L/Au:N/C:P/I:P/A:P|
Scanning For and Finding Vulnerabilities in PHP Running Version Prior to 5.3.22
Use of Vulnerability Management tools, like AVDS, are standard practice for the discovery of this vulnerability. The primary failure of VA in finding this vulnerability is related to setting the proper scope and frequency of network scans. It is vital that the broadest range of hosts (active IPs) possible are scanned and that scanning is done frequently. We recommend weekly. Your existing scanning solution or set of test tools should make this not just possible, but easy and affordable. If that is not the case, please consider AVDS.
Penetration Testing (pentest) for this Vulnerability
The Vulnerabilities in PHP Running Version Prior to 5.3.22 is prone to false positive reports by most vulnerability assessment solutions. AVDS is alone in using behavior based testing that eliminates this issue. For all other VA tools security consultants will recommend confirmation by direct observation. In any case Penetration testing procedures for discovery of Vulnerabilities in PHP Running Version Prior to 5.3.22 produces the highest discovery accuracy rate, but the infrequency of this expensive form of testing degrades its value. The ideal would be to have pentesting accuracy and the frequency and scope possibilities of VA solutions, and this is accomplished only by AVDS.
Security Updates on Vulnerabilities in PHP Running Version Prior to 5.3.22
For the most current updates on this vulnerability please check www.securiteam.com Given that this is one of the most frequently found vulnerabilities, there is ample information regarding mitigation online and very good reason to get it fixed. Hackers are also aware that this is a frequently found vulnerability and so its discovery and repair is that much more important. It is so well known and common that any network that has it present and unmitigated indicates "low hanging fruit" to attackers.
Confirming the Presence of Vulnerabilities in PHP Running Version Prior to 5.3.22
AVDS is currently testing for and finding this vulnerability with zero false positives. If your current set of tools is indicating that it is present but you think it is probably a false positive, please contact us for a demonstration of AVDS.
The secret killer of VA solution value is the false positive. There was an industry wide race to find the most vulnerabilities, including Vulnerabilities in PHP Running Version Prior to 5.3.22 ,and this resulted in benefit to poorly written tests that beef up scan reports by adding a high percentage of uncertainty. This may have sold a lot of systems some years ago, but it also stuck almost all VA solutions with deliberately inaccurate reporting that adds time to repairs that no administrator can afford. Beyond Security did not participate in this race to mutually assured destruction of the industry and to this day produces the most accurate and actionable reports available.
Patching/Repairing this Vulnerability
Upgrade to PHP version 5.3.22 or newer.
Please also visit www.securiteam.com to view any exploits available for this vulnerability, or search using "Vulnerabilities in PHP Running Version Prior to 5.3.22".